EIGRP (Enhanced Interior Gateway Routing Protocol)

EIGRP (Enhanced Interior Gateway Routing Protocol) adalah routing protocol yang hanya diadopsi oleh router cisco atau sering disebut sebagai proprietary protocol pada cisco. EIGRP sering disebut juga hybrid-distance-vector routing protocol. Selain itu, EIGRP adalah protocol routing yang termasuk proprietary cisco, yang berarti hanya bisa dijalankan pada router cisco.

Fitur-fitur pada EIGRP :

  • Termasuk protokol routing distance vector tingkat lanjut (Advanced distance vector).
  • Waktu convergence yang cepat.
  • Mendukung VLSM dan subnet-subnet yang discontiguous (tidak bersebelahan/berurutan)
  • Partial updates, Tidak seperti RIP yang selalu mengirimkan keseluruhan tabel routing dalam pesan Update, EIGRP menggunakan partial updates atau triggered update yang berarti hanya mengirimkan update jika terjadi perubahan pada network (mis: ada network yang down)
  • Mendukung multiple protokol network
  • Desain network yang flexible.
  • Algoritma yang digunakan adalah Diffusing Update Algorithm (DUAL) untuk menghitung jalur terpendek.
  • Multicast dan unicast, EIGRP saling berkomunikasi dengan tetangga (neighbor) nya secara multicast (224.0.0.10) dan tidak membroadcastnya.
  • Manual summarization, EIGRP dapat melakukan summarization dimana saja.
  • Menjamin 100% topologi routing yang bebas looping.
  • Mudah dikonfigurasi untuk WAN dan LAN.
  • Load balancing via jalur dengan cost equal dan unequal, yang berarti EIGRP dapat menggunakan 2 link atau lebih ke suatu network destination dengan koneksi bandwidth (cost metric) yang berbeda, dan melakukan load sharing pada link-link tersebut dengan beban yang sesuai yang dimiliki oleh link masing-masing, dengan begini pemakaian bandwidth pada setiap link menjadi lebih efektif, karena link dengan bandwidth yang lebih kecil tetap digunakan dan dengan beban yang sepadan juga

Kelebihan EIGRP:

  • mudah dikonfigurasi semudah RIP.
  • Kombinasi terbaik dari protokol distance vector dan link state.
  • Mendukung IP, IPX, dan AppleTalk melalui modul-modul yang bersifat protocol dependent.
  • Pencarian network tetangga yang dilakukan dengan efisien.
  • Komunikasi melalui Reliable Transport Protocol (RTP).
  • Summarization dapat dilakukan dimana saja dan kapan saja pada OSPFsummarization
  • hanya bisa dilakukan di ABR dan ASBR.
  • Pemilihan jalur terbaik melalui Diffusing Update Algoritma (DUAL).
  • EIGRP satu-satunya yang dapat melakukan uneqal load balancing.

Kekurangan EIGRP :

  • Hanya bisa di implementasikan pada Router Cisco.
  • Protocol Cisco-propitary, sehingga jika diterapkan pada jaringan multivendor diperlukan suatu fungsi yang disebut route redistribution. Fungsi ini akan menangani proses pertukaran rute router di antara dua protokol link state (OSPF dan EIGRP).

EIGRP menggunakan 4 teknologi kunci yang berkombinasi untuk membedakan EIGRP dengan protokol routing yang lainnya:

  • Neighbor discovery/recovery
  • Menggunakan paket hello antar neighbor.
  • Pengiriman paket yang terjamin dan terurut kepada semua neighbor.
  • Memilih jalur dengan cost paling rendah dan bebas looping untuk mencapai destination.
  • EIGRP dapat mendukung IP, AppleTalk, dan Novell NetWare.
  • Setiap protokol disediakan modul EIGRP tersendiri dan beroperasi tanpa saling mempengaruhi satu sama lain.
  • Reliable Transport Protocol (RTP)
  • DUAL finite-state machine
  • Protocol-dependent module (PDM)

 Konfigurasi EIGRP

Gambar Topology dengan mengunakan EIGRP

ROUTER 1 :

router# configure terminal

router(config)#hostname router1

router1(config)#interface fastethernet0/0

router1(config-if)#ip address 20.20.20.1 255.0.0.0

router1(config-if)#no shutdown

router1(config-if)#exit

router1(config)#interface serial0/0/0

router1(config-if)#ip address 140.140.140.1 255.255.0.0

router1(config-if)#no shutdown

router1(config-if)#exit

router1(config)#interface serial0/0/1

router1(config-if)#ip address 200.200.200.1 255.255.255.0

router1(config-if)#clock rate 64000

router1(config-if)#no shutdown

router1(config-if)#exit

router1(config)#router eigrp 10

router1(config-router)#network 20.0.0.0

router1(config-router)#network 140.140.0.0

router1(config-router)#network 200.200.200.0

router1(config-router)#exit

router1(config)#exit

 

ROUTER 2 :

router# configure terminal

router(config)#hostname router2

router2(config)#interface fastethernet0/0

router2(config-if)#ip address 198.100.100.1 255.255.255.0

router2(config-if)#no shutdown

router2(config-if)#exit

router2(config)#interface serial0/0/0

router2(config-if)#ip address 140.140.140.2 255.255.0.0

router2(config-if)#no shutdown

router2(config-if)#exit

router2(config)#interface serial0/0/1

router2(config-if)#ip address 10.10.10.1 255.0.0.0

router2(config-if)#clock rate 64000

router2(config-if)#no shutdown

router2(config-if)#exit

router2(config)#router eigrp 10

router2(config-router)#network 198.100.100.0

router2(config-router)#network 140.140.0.0

router2(config-router)#network 10.0.0.0

router2(config-router)#exit

router2(config)#exit

 

ROUTER 3 :

router# configure terminal

router(config)#hostname router3

router3(config)#interface fastethernet0/0

router3(config-if)#ip address 150.140.140.1 255.255.0.0

router3(config-if)#no shutdown

router3(config-if)#exit

router3(config)#interface serial0/0/0

router3(config-if)#ip address 10.10.10.2 255.0.0.0

router3(config-if)#no shutdown

router3(config-if)#exit

router3(config)#interface serial0/0/1

router3(config-if)#ip address 7.7.7.1 255.0.0.0

router3(config-if)#clock rate 64000

router3(config-if)#no shutdown

router3(config-if)#exit

router3(config)#router eigrp 10

router3(config-router)#network 150.140.0.0

router3(config-router)#network 10.0.0.0

router3(config-router)#network 7.0.0.0

router3(config-router)#exit

router3(config)#exit

 

ROUTER 4 :

router# configure terminal

router(config)#hostname router4

router4(config)#interface fastethernet0/0

router4(config-if)#ip address 135.135.135.1 255.255.0.0

router4(config-if)#no shutdown

router4(config-if)#exit

router4(config)#interface serial0/0/0

router4(config-if)#ip address 200.200.200.2 255.255.255.0

router4(config-if)#no shutdown

router4(config-if)#exit

router4(config)#interface serial0/0/1

router4(config-if)#ip address 7.7.7.2 255.0.0.0

router4(config-if)#clock rate 64000

router4(config-if)#no shutdown

router4(config-if)#exit

router4(config)#router eigrp 10

router4(config-router)#network 135.135.0.0

router4(config-router)#network 200.200.200.0

router4(config-router)#network 7.0.0.0

router4(config-router)#exit

router4(config)#exit

 

Kelompok I

  • Ahmad Ekky S.K  (11142235)
  • David Sanjaya  (11142256)
  • Muhammad Listanto S  (11142256)
  • Ria Dwi Lestari  (11142236)
  • Ridwan Akbar  (11142222)

Download EIGRP (Enhanced Interior Gateway Routing Protocol)

Leave a Reply

Your email address will not be published. Required fields are marked *